WCF Service not Running after TargetFramework changed from 3.5 to 4.0

Last Reply 9 days ago By dharmendr

Posted 12 days ago

Hi,

I have WCF Service Project which is in .NET version 3.5 (VS2008) and the running pool is Classic .NET App pool, to Upgrade to .NET version 4.0, Project Migrated to VS2010, then in IIS Manager when Classic .NET App pool was selected there is an Error message while opening "Directory Browsing". the Error Message is adding below

"The configuration section 'system.web.extensions' cannot be read because it is missing a section declaration"

The Error Message is not appearing when selected any other App pool.

after Upgradation is it necessary to change app pool to ASP.NET v4.0 Classic .NET AppPool or Some other.
anyway i tried every App pool. when selected App pool ASP.NET v4.0 Classic .NET AppPool , while browsing .svc file the following Error is displaying

"Screenshot of browser when APP POOL is "ASP.NET v4.0 Classic .NET AppPool"".

ManuKrish has viewed this question 7 days ago.
Results 1 - 5 of 7 12

Posted 9 days ago

thank you for the reply, the error message is not showing, but still the output is not expected.this is what i get when the .svc file is browsed.

 

HTTP Error 500. An internal server error has occured.

please help 


Posted 9 days ago

Hi ManuKrish,

Please upload the screenshots to http://imgur.com/ and
copy the link from Direct Link option and add to the screenshot in the editor.

How to add image or screenshot to the Editor


Posted 9 days ago

App pool list

Apppool list from IIS Manager


Posted 9 days ago Modified on 9 days ago

Error Mesage

Error Message