ASP.Net Error: Microsoft SharePoint is not supported with version 4.0.30319.42000 of the Microsoft .Net Runtime

Last Reply 18 days ago By dharmendr

Posted 19 days ago

I created a Web API using .NET 4.5 and referencing .NET 3.5 library that uses the Sharepoint 2010 libraries.

I am getting a below mentioned error :

"Microsoft SharePoint is not supported with version 4.0.30319.42000 of the Microsoft .Net Runtime."

I know that SharePoint is compatable with CLR2.0.

Is there any why, I can make my WebAPI to communicate with Sharepoint 2010.


Posted 18 days ago Modified on 18 days ago

Not working.....

I am not using power shell programming. I am trying to acceess DLL from by web api. 

This DLL is working for Console and Web Service with .Net2.0 but not with .Net4.0 and above.

Below is the combination I am using :

Sharepoint  2010.

DLL V2.0

WebAPI : v4.0