[Solved] ASP.Net Core NodeServices Error: Failed to start Node process

Last Reply one month ago By dharmendr

Posted one month ago

Greetings Sir,

Please I installed Node.js on my /bin/Debug/netcoreapp3.1, it is running JavaScript app locally using NodeServices on my backend, via my PC.... but I deployed it on production to be sure it will work and it is giving me all sort of errors... It was giving me these errors before I installed it on the above location. 

Now, what I wanted to is if there a way to include all the project folders during Publish using V.S.... is there anyway you can help me sir?? Thank... Or is there a better way to run JavaScript on Asp.net core backend.

Thanks 

Check the link below to see the errors https://test.destrotech.com.ng

InvalidOperationException: Failed to start Node process. To resolve this:. [1] Ensure that Node.js is installed and can be found in one of the PATH directories. Current PATH enviroment variable is: C:\Program Files (x86)\Parallels\Plesk\Mail Servers\Mail Enable\BIN;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\Parallels\Plesk\Mail Servers\Mail Enable\BIN64;C:\Program Files (x86)\Microsoft SQL Server\110\Tools\Binn\;C:\Program Files\Microsoft SQL Server\110\Tools\Binn\;C:\Program Files\Microsoft SQL Server\110\DTS\Binn\;C:\Users\Default\.dnx\bin;C:\Program Files\Microsoft DNX\Dnvm\;C:\Program Files\Microsoft SQL Server\130\Tools\Binn\;C:\Program Files (x86)\PuTTY\;C:\Program Files\Microsoft\Web Platform Installer\;C:\Program Files\dotnet\;C:\Program Files (x86)\Bitvise SSH Client;C:\Program Files\BackupClient\CommandLineTool\;C:\Program Files (x86)\Common Files\Acronis\FileProtector\;C:\Program Files (x86)\Common Files\Acronis\FileProtector64\;C:\Program Files\BackupClient\PyShell\bin\;C:\Program Files (x86)\Common Files\Acronis\SnapAPI\;C:\Program Files (x86)\dotnet\;C:\Program Files (x86)\Microsoft ASP.NET\ASP.NET Web Pages\v1.0\;C:\Program Files (x86)\Parallels\Plesk\ctl;C:\Program Files\Git\cmd; Make sure the Node executable is in one of those directories, or update your PATH. [2] See the InnerException for further details of the cause.

You are viewing reply posted by: dharmendr one month ago.