ASPForums.Net RSS Feedhttp://www.aspforums.net/Handlers/RSS.ashxLatest additions to the content that appears on ASPForums.Net(c) 2019 www.aspforums.com. All rights reserved.login button not working in content page with url rewrites<p>Will you please share your complete code.</p>https://www.aspforums.net:443/Threads/250277/login-button-not-working-in-content-page-with-url-rewrites/https://www.aspforums.net:443/Threads/250277/login-button-not-working-in-content-page-with-url-rewrites/Mon, 28 Mar 2016 08:33:49 GMTlogin button not working in content page with url rewrites<p>i have many pages in my site with master page .</p> <p>every page commit with master page . i have a login window in master page ..its work every page perfect .</p> <p>but when i url rewrite of serch page then he work perfect when url rewrite .</p> <p>easyshiksha/engineering</p> <p><span style="font-size: 10pt; background-color: #ffffff;">rewrite&nbsp;</span></p> <p><a href="http://easyshiksha.com/search.aspx?q=&amp;loc=&amp;course_level=&amp;course_map1=btech">http://easyshiksha.com/search.aspx?q=&amp;loc=&amp;course_level=&amp;course_map1=btech</a> &amp;course_map2=&amp;states=1</p> <p>but when i going with previous url with query string there login not work no error there. only end of url write &nbsp;see &nbsp;#stq&amp;stp=1</p> <p>my master page code for login he is in master page ..</p> <pre class="brush: csharp">protected void m_log_Click(object sender, EventArgs e) { ds = new DataSet(); string sql2 =&#34;Select * From user_Information where email=@email2 and password=@password2 &#34;; cmd2 = new SqlCommand(sql2); cmd2.Parameters.AddWithValue(&#34;@email2&#34;, m_email_signin.Value); cmd2.Parameters.AddWithValue(&#34;@password2&#34;, m_password_signin.Value); ds = obj.selectds1(cmd2, &#34;user_Information&#34;); //ds = obj.select(&#34;Select * From user_Information where email=&#39;&#34; + m_email_signin.Value + &#34;&#39; and password=&#39;&#34; + m_password_signin.Value + &#34;&#39;&#34;, &#34;user_Information&#34;); if (ds.Tables[&#34;user_Information&#34;].Rows.Count &gt; 0) { HttpCookie login = new HttpCookie(&#34;user_login&#34;); login.Value = ds.Tables[&#34;user_Information&#34;].Rows[0][&#34;user_id&#34;].ToString(); login.Expires = DateTime.Now.AddYears(1); Response.Cookies.Add(login); // string choice = HttpUtility.UrlEncode(Encrypt(ds.Tables[0].Rows[0][&#34;education_interest&#34;].ToString())); string choice = ds.Tables[0].Rows[0][&#34;education_interest&#34;].ToString(); //Response.Redirect(string.Format(&#34;users.aspx?q={0}&amp;loc=&amp;course_level=&amp;course_map1=&amp;course_map2=&#34;, choice)); Response.Redirect(&#34;users.aspx?q=&#34;+choice+&#34;&amp;loc=&amp;course_level=&amp;course_map1=&amp;course_map2=&#34;); } else { inc_login.Style.Add(&#34;display&#34;, &#34;inline&#34;); showp.Style.Add(&#34;display&#34;, &#34;none&#34;); } }</pre> <p>url rewrite</p> <p>&lt;rule name="Rewrite Rule"&gt; &lt;match url=".*" /&gt; &lt;conditions&gt; &lt;add input="{StaticRewrites:{PATH_INFO}}" pattern="(.+)" /&gt; &lt;/conditions&gt; &lt;action type="Rewrite" url="{C:1}" /&gt; &lt;/rule&gt;</p>https://www.aspforums.net:443/Threads/250277/login-button-not-working-in-content-page-with-url-rewrites/https://www.aspforums.net:443/Threads/250277/login-button-not-working-in-content-page-with-url-rewrites/Mon, 28 Mar 2016 23:25:18 GMTlogin button not working in content page with url rewrites<p>when click on login button end of url .</p> <p>http://easyshiksha.com/search.aspx?q=IFLUX%20IIT%20&amp;MEDICAL%20ACADEMY%20(COACHING%20CLASSES%20V11%20TO%20X11TH%20)&amp;loc=&amp;course_level=&amp;course_map1=&amp;course_map2=&amp;states=1<strong>#stq=&amp;stp=1</strong></p> <p>&nbsp;</p> <p><strong>this is come in url ..</strong></p> <p>&nbsp;</p>https://www.aspforums.net:443/Threads/250277/login-button-not-working-in-content-page-with-url-rewrites/https://www.aspforums.net:443/Threads/250277/login-button-not-working-in-content-page-with-url-rewrites/Tue, 29 Mar 2016 01:15:56 GMTlogin button not working in content page with url rewrites<p>Hi ps222,</p> <p>Try to add below line in the Page_Load event of the master page.</p> <pre class="brush: csharp">protected void Page_Load(object sender, EventArgs e) { form1.Action = Request.RawUrl; } </pre> <p>Here 'form1' is the asp form used in the master page.</p>https://www.aspforums.net:443/Threads/250277/login-button-not-working-in-content-page-with-url-rewrites/https://www.aspforums.net:443/Threads/250277/login-button-not-working-in-content-page-with-url-rewrites/Tue, 29 Mar 2016 02:14:34 GMTlogin button not working in content page with url rewrites<p>i try it advance ...sir ..</p>https://www.aspforums.net:443/Threads/250277/login-button-not-working-in-content-page-with-url-rewrites/https://www.aspforums.net:443/Threads/250277/login-button-not-working-in-content-page-with-url-rewrites/Tue, 29 Mar 2016 02:17:26 GMTlogin button not working in content page with url rewrites<p>On every button click "<strong>#stq=&amp;stp=1</strong>" string is appended is common for every url generated?</p>https://www.aspforums.net:443/Threads/250277/login-button-not-working-in-content-page-with-url-rewrites/https://www.aspforums.net:443/Threads/250277/login-button-not-working-in-content-page-with-url-rewrites/Tue, 29 Mar 2016 05:13:54 GMTlogin button not working in content page with url rewrites<p>no only search page...&nbsp;</p>https://www.aspforums.net:443/Threads/250277/login-button-not-working-in-content-page-with-url-rewrites/https://www.aspforums.net:443/Threads/250277/login-button-not-working-in-content-page-with-url-rewrites/Tue, 29 Mar 2016 05:39:08 GMTlogin button not working in content page with url rewrites<p>I mean to say on clicking login button every time the same string i.e. "<strong>#stq=&amp;stp=1</strong>" is appended to the url or it is different for any other condition.</p>https://www.aspforums.net:443/Threads/250277/login-button-not-working-in-content-page-with-url-rewrites/https://www.aspforums.net:443/Threads/250277/login-button-not-working-in-content-page-with-url-rewrites/Tue, 29 Mar 2016 08:57:41 GMTlogin button not working in content page with url rewrites<p>i got answer add validate request="false" in default.aspx.</p> <p>&nbsp;</p> <p>thanks</p>https://www.aspforums.net:443/Threads/250277/login-button-not-working-in-content-page-with-url-rewrites/https://www.aspforums.net:443/Threads/250277/login-button-not-working-in-content-page-with-url-rewrites/Tue, 29 Mar 2016 23:34:21 GMT